BusinessPack Messaging

I’m try to use the ChatGpt demo from here (dotvvm-minutes/16_ChatGPTStreaming/ChatGptBusinessPackMessaging at master · riganti/dotvvm-minutes · GitHub).

When I load the solution the preview library for DotVVM.BusinessPack.Messaging used by the solution is now longer available so I have tried to use 4.1.3.

When starting the solution it fails trying to reference _messaging.GetConnection(“ChatGpt”). Could you tell me what this should be so that I can get the demo to work?


Receiving exactly the same result on implementing in my application. Has this variable changed in the later version of the library?

I am sorry for the issue. The video was created when we had only an internal preview of the library released.

I have updated the repo to DotVVM 4.2 including Business Pack Messaging, and also a new API of the Azure OpenAI (the old library would stop working soon).

Thank you Tomas! I can now get your demo working but I am still seeing an issue when I migrate the changes into my application. I am seeing the following error. Do you have any pointers as to what might be causing this?